Skip to end of metadata
Go to start of metadata

Hipster 2016.04 is here

So, after half a year we have new ISO:
http://dlc.openindiana.org/isos/hipster/20160421/OI-hipster-gui-20160421.iso
http://dlc.openindiana.org/isos/hipster/OI-hipster-gui-20160421.usb 

http://dlc.openindiana.org/isos/hipster/20160421/OI-hipster-text-20160421.iso
http://dlc.openindiana.org/isos/hipster/20160421/OI-hipster-text-20160421.usb

Corresponding sha256 cheksums are available at ${link}.sha256sum location.

As always, there were a lot of changes since last snapshot.

General system changes

New nlipkg zone brand was introduced, which behaves like old ipkg brand (i.e. it doesn't check child and parent images for consistency). It's possible to convert ipkg zone to nlipkg one. To do so, install system/zones/brand/nlipkg, change zone's brand to nlipkg and remove /var/pkg/linked inside zone.

Closed sysidtool which could be used to set initial system parameters on first boot and initialize zone's configuration  was replaced with sysding. All other packages from closed admin incorporation were also removed.

Now we publish userland-incorporation, which has to be installed on user's system and restricts all installed software versions. This helps in identifying non-compatible packages. If you need to relax it, you can use facets.

Text installer now can configure network parameters using sysding.

Updates from unmaintained OpenIndiana /dev version to /hipster should be possible now. See this instruction .

Note, that this is the last snapshot which in some way supports 32-bit systems. Compatibility for running 32-bit applications on 64-bit systems will be preserved.

Desktop software and libraries

  • Firefox is updated to 45.0.2
  • Thunderbird is updated to 38.6.0
  • Mesa 11.1.2 implemented
  • GTK 3 3.14.15 is added. GTK 2 is updated to 2.24.29 and stays default for now.
  • vlc 2.2.1 is added to /hipster-encumbered
  • ffmpeg is updated to 2.8.6
  • libusb-1.0 is added, libmtp is switched from libusb to libusb-1.0

  • fuse driver and libfuse 2.7.6 are integrated. sshfs is added.

  • dbus is updated to 1.10.8

  • libotr is updated to 4.1.1

  • openttd is updated to 1.5.3

  • geany 1.26 is added

  • hexchat 2.12.0 is added
  • lynx is updated to 2.8.8

  • mutt is updated to 1.6.0
  • X11 libraries and tools were updated
  • libical is updated to binary incompatible version 1.0.
  • libnotify is updated to ABI-incompatible 0.7.6 version
  • postrun service (which was JDS private interface to make post-installation tasks) was removed
  • Unmaintained visual panels were dropped
  • EsounD was removed (superseded by pulseaudio)
  • Openproj was removed

Development tools and libraries

  • GCC 4.9 was added It's the default oi-userland compiler now. GCC 4.7 and Clang 3.3 are removed

  • Automake 1.15 was added, now it's default automake
  • Erlang was updated to 17.5
  • Ruby-23 was added, Ruby-22 is updated to 2.2.4
  • OpenSSL is updated to 1.0.2g

  • PHP 5.6.20 is added, PHP 5.5 is updated to 5.5.34, PHP 5.4.45 is still shipped, but can be removed before next snapshot.

  • Perl is updated to 5.22.1
  • Python and modules were updated, python 2.6 stays default python for now as it's required by illumos-gate
  • GDB is updated to 7.10.1

  • beanshell is updated to 2.0b6
  • SCons 2.4.1 is added
  • SDL2 2.0.4 is added
  • curl is updated to 7.47.0
  •  check is updated to 0.10.0
  • OpenBLAS is updated to 0.2.15
  • OpenMPI is updated to 1.10.1
  • MPICH is updated to 3.2
  • libjpeg-turbo 1.4.2 is added (IGJ libjpeg stays default libjpeg 6)
  • unixODBC is updated to 2.3.4
  • libpcap is updated to 1.7.4
  • openssl-fips package was removed

Server software

  • Apache 2.4 is updated to 2.4.20. Now it ships mod_http2 to suport HTTP/2 connections

  • Nginx is updated to 1.8.1

  • Now OpenSSH 7.2p2 can be used instead of Sun SSH. It comes with a lot of illumos-specific patches from Oracle and Joyent. To use it, just install openssh. It is installed by default on new systems. To switch back change ssh mediator implementation to sunssh.

  • PostgreSQL 9.5.2 is added, PostgreSQL 9.4 and 9.3 are updated to 9.4.7 and 9.3.12

  • Bind is updated to 9.10.3-P4. Now it runs as "named" user, so check that your configs are accessible to it.

  • Samba is updated to 4.2.11. vfs_solarisacl module is compiled as static module now. Samba 3.6 is removed.

  • Borg backup tool 1.0.0 is added

  • Percona server 5.7.10.3 is added. Percona-server 5.5 and 5.6 are updated to 5.5.48.37.8, 5.6.29.76.2. MariaDB is updated to 5.5.47

  • Squid is updated to 3.5.15

  • Tomcat 8 is updated to 8.0.32

  • ISC DHCPD is updated to 4.3.3-P1

  • KVM is updated to 20160303 Joyent version

  • mosh 1.2.5 is added

Other tools

  •  Hunspell / Myspell dictionaries were updated. Dictionaries for af_ZA, bg_BG, ca_ES, da_DK, el_GR, en_ZA, eo_l3, et_EE, fa_IR, fo_FO, ga_IE, gd_GB, gl_ES, gv_IE, he_IL, hr_HR, hy_AM, ku_TR, lt_LT, lv_LV, nb_NO, nl_NL, nn_NO, nr_ZA, ns_ZA, pt_PT, ro_RO, sk_SK, sl_SI, ss_ZA, st_ZA, th_TH, tn_ZA, ts_ZA languages were removed.

  • bash is updated to 4.3.42

  • zsh is updated to 5.2

  • mozilla-nss is updated to 3.23

  • mozilla-nspr is updated to 4.12
  • socat is updated to 1.7.3.1
  • rsync is updated to 3.1.2
  • gawk is updated to 4.1.3
  • wget was updated to 1.17.1 

  • less was updated to 481 

  • gzip is updated to 1.7 
  • GNU grep is updated to 2.24
  • tuntap was updated to latest head (43816b1). 

As always, we are proud to deliver to you latest illumos-gate bits (i.e. illumos-f83b46b).

There's also a lot of security fixes and small bug fixes.

As for missing things, we would like to update to latest Xorg, but we still miss radeon driver for it.
More updates to X11 libraries are coming, as well as PHP 7.0.5.

I'd like to mention that all JDS components, present in /dev, were moved to oi-userland. As for oi-userland itself, its tools are switched to python 2.7. Components are moving to categories according to categories layout. Logic for publishing renamed/obsolete packages was imported from upstream userland-gate.