Skip to end of metadata
Go to start of metadata

Binaries

On OpenIndiana Hipster,  LibreOffice 4.4.7 is available from SFE since Jan 1th 2016.

Libreoffice 5.2.5.1 is available since Feb 5th 2017

(History: LibreOffice 4.4.5 is available from SFE since Aug. 2015)

Building notes

Many thanks to Peter Tribble for his invaluable work:

http://ptribble.blogspot.co.uk/2015/06/building-libreoffice-on-tribblix.html

Prerequirements for 4.4.3.2

Reference: https://wiki.documentfoundation.org/DLP/Libraries

DLP projects: http://www.documentliberation.org/projects/

 

ComponentVersionOI VersionProject URLArchive URLComment
cppunit1.13.21.13.2http://www.freedesktop.org/wiki/Software/cppunit/http://dev-www.libreoffice.org/src/cppunit-1.13.2.tar.gz
  • PR #860

librevenge

0.0.40.0.2https://sourceforge.net/p/libwpd/wiki/librevenge/http://sourceforge.net/projects/libwpd/files/librevenge/librevenge-0.0.2/librevenge-0.0.2.tar.xz/download
  • Pass --disable-werror to configure
  • PR #1336
libodfgen0.1.60.1.4https://sourceforge.net/p/libwpd/wiki/libodfgen/http://sourceforge.net/projects/libwpd/files/libodfgen/libodfgen-0.1.4/libodfgen-0.1.4.tar.xz/download
  • PR #1338
libwpd0.10.10.10.0https://sourceforge.net/projects/libwpdhttp://sourceforge.net/projects/libwpd/files/libwpd/libwpd-0.10.0/libwpd-0.10.0.tar.xz/download
  • PR #1343
libwpg0.3.10.3.0https://sourceforge.net/projects/libwpghttp://sourceforge.net/projects/libwpg/files/libwpg/libwpg-0.3.0/libwpg-0.3.0.tar.bz2/download
  • PR #1344
libmspub0.1.2 https://wiki.documentfoundation.org/DLP/Libraries/libmspubhttp://dev-www.libreoffice.org/src/libmspub/libmspub-0.1.2.tar.xz
  • Replace the call to pow() in src/lib/MSPUBMetaData.cpp with std::pow()
  • Remove zlib from the installed pc file (Tribblix, and some of the other illumos other distros, don't supply a pkgconfig file for zlib) Not OI Hipster.
  • PR #1348
libwps0.4.3 https://sourceforge.net/projects/libwpshttp://sourceforge.net/projects/libwps/files/libwps/libwps-0.4.0/libwps-0.4.0.tar.xz/download
  • PR #1349
libcdr0.1.3 https://wiki.documentfoundation.org/DLP/Libraries/libcdrhttp://dev-www.libreoffice.org/src/libcdr/libcdr-0.1.1.tar.xz
  • PR #2337 (needed for inkscape)
mdds0.11.2   
  • Make sure you have a PATH that has the gnu install ahead of the system install program when running make install.
 
libixion0.7.0   
  • Need some way of getting -pthreads past configure *and* make. For configure, I [Peter] used:

    env boost_cv_pthread_flag=-pthreads CFLAGS="-O -pthreads" CPPFLAGS="-pthreads" CXXFLAGS="-pthreads" configure ...


    and for make:

    gmake MDDS_CFLAGS=-pthreads
liborcus0.7.0   
  • Run the following against all the Makefiles that the configure step generates:

    gsed -i 's:-DMDDS_HASH_CONTAINER_BOOST:-pthreads -DMDDS_HASH_CONTAINER_BOOST:'
  • It looks to pkgconfig to find zlib, so you'll need to prevent that:

     env ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-lz" configure ...
libvisio0.1.1
 https://wiki.documentfoundation.org/DLP/Libraries/libvisio 
  • Replace the call to pow() in src/lib/VSDMetaData.cpp with std::pow()
  • Remove zlib and libxml-2.0 from the installed pc file
Labels:
  1. Nov 27, 2015

    Based on all that great work and added some more, SFE contributor pjama made SFElibreoffice4.spec possible.

    As an early, "first shot" binary package there is SFElibreoffice4 available for OI-Hipster:

    You can install the "libreoffice4" package from the publisher "localhostoih" described in the link below. But please make sure, to uninstall older revisions of the "icu", "boost" packages from the OIHipster repositories.

    Read http://sfe.opencsw.org for the IPS repository instructions and updates for the package.