Child pages
  • oi_hipster

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.


Note
titleDeprecation warning

The page has been migrated to https://docs.openindiana.org/release-notes/latest-changes/ . Avoid touching this wiki page.

Hipster repository

Current repository is located at:

...

Code Block
pkg set-publisher -g http://pkg.openindiana.org/hipster --search-first openindiana.org

Changelog

2019-05-06 PHP 7.3 was introduced

2019-05-05 Mate was updated to 1.22

2019-04-28 Firefox was updated to 60.6.1 ESR

2019-03-01 PHP 5.6 is removed.

2019-03-01 apache-24 is 64-bit-only now. File and configuration layout is changed. Manual intervention will be likely required on update to fix service. Look for details in this announcement.

2019-01-10 fish shell was updated to version 3.0.0, which has some non-backward compatible changes, for more information see fish release notes.

2018-12-13 libsodium was updated to ABI-incompatible version 1.0.16. All dependent applications should be rebuilt.

2018-12-06 VirtualBox 5.2.22 was added

2018-10-25 GtkHTML 3.32.2 (library/desktop/gtkhtml) was removed. The only consumer, evolution, had been removed long before.

2018-10-22 Components lame and twolame were moved from encumbered to userland. Gstreamer updated to 1.14.4.

2018-10-19 IPS was updated to include new fixes from Oracle and OmniOS CE (up to 93b48ac487d97ffef1711361697f1e929b744c01 )

2018-10-14 GTK 3 was updated to 3.24.1. Mate was updated to 1.20. Nimbus GTK3 theme was rebased on Solaris 11 theme from B00merang project.

2018-10-03 KVM zone brand was integrated. Now you can get additional isolation level for kvm and manage kvm VMs as zones. Some examples are available here: https://github.com/OpenIndiana/pkg5/blob/oi/doc/kvm.md

2018-09-27 ghostscript was updated to 9.25. This is ABI-incompatible update. All dependent packages should be rebuilt.

2018-09-24 distro_const doesn't longer create 32-bit boot archive. GUI and text installer were modified to cope with this. If you used custom disto-const manifests, be sure to remove <script name="/usr/share/distro_const/boot_archive_archive_32"> section from them.

2018-09-01 Samba was updated to 4.8.4

2018-08-28 BerkeleyDB 5.1 compatibility symlinks were removed.

2018-07-27 Tomcat 6 ( web/java-servlet/tomcat ) was removed. Use Tomcat 8 (web/java-servlet/tomcat-8) instead.

2018-07-26 Libpqxx was updated to incompatible version 6.2.4, all dependent packages should be recompiled.

2018-06-21 Postfix updated to 3.3.1, configuration format changed in version 3.2 and 3.3, be sure to read the changes in postconf(5).

2018-05-21 hwloc updated to 2.0.1 is ABI incompatible, dependent libraries such as PETSc need rebuild.

2018-05-05 ghostcript was updated to likely ABI-incompatible 9.23 version.

2018-02-12 GCC 6 is the default oi-userland compiler now. Read announce email for details.

2018-01-23 gdm, libunique, gnome-power manager are removed. Support for creating Gnome2 installation images was removed.

2018-01-22 upower 0.99.7 and mate-power-manager 1.18.1 were added

2017-12-22 asterisk was updated to 15.1.4

2017-12-21 nautilus, file-roller, gnome-control-center and evolution were removed. You can use Mate analogs (caja, engrampa, mate-control-center) and thunderbird instead.

2017-12-20 totem was updated to 3.0.1

2017-12-12 audacity 2.1.1 was added to /hipster-encumbered repository.

2017-11-25 samba was updated to 4.5.15

2017-11-25 library/gnu-libiconv was removed. Applications should use illumos native iconv interface.

2017-11-17 IPS sysem repository is now working on OpenIndiana. Documentation was updated: http://docs.openindiana.org/handbook/systems-administration/#zones (look at "System repository configuration").

2017-10-27 Xorg was updated to 1.19.5. Note, that if you run OI as VirtualBox guest, you should switch to vesa driver, as latest VirtualBox guest additions (currently 5.1.30 or 5.2.0) don't provide Solaris xorg drivers for Xorg 1.19.

2017-10-17 net-snmp was updated to ABI-incompatible version 5.7.3. All dependent packages should be recompiled.

2017-10-14 PostgreSQL 9.3 was removed. PostgreSQL 9.4 is the default PostgreSQL version now. PostgreSQL 10 was added.

2017-08-30 goffice was updated to ABI-incompatible 0.10.35 version, all dependent software should be recompiled

2017-08-10 libgcrypt was updated to ABI-incompatible 1.8.0 version, all dependent software should be recompiled

2017-08-10 libgpg-error was updated to 1.27. Due to fix in ligpg-error headers, ABI incompatibility is possible. Dependent applications should be recompiled.

2017-08-08 apache 2.2 was removed. Users are advised to switch to apache 2.4.

2017-07-26 libgphoto2 was updated to ABI-incompatible 2.5.14 version. All dependent applications should be rebuilt.

2017-07-19 Tcl/Tk were updated to 8.6.6. Default tclsh is 64-bit now. Third-party modules likely should be recompiled/reinstalled due to the change of the search path .

2017-07-01 GeoIP was updated to 1.6.11. geoip-database shipping GeoIP databases was added to oi-userland.

2017-06-23 MariaDB 5.5 and Percona Server 5.5 were removed. MariaDB 10.1 is the default MySQL implementation now.

2017-05-31 Mate was updated to 1.18

2017-05-22 Thunderbird was updated to 52.1.1

2017-05-16 VLC was updated to 2.2.5.1

...