Child pages
  • oi_hipster
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 63 Next »

Changelog

2015-02-17 xorg-video-intel X device driver was updated to 2.99.917

2015-02-15 Xorg server was updated to 1.12.4. All X device drivers updated. All 32-bit-only X device drivers removed.

2015-02-13 X video drivers xorg-video-ast, xorg-video-mach64, xorg-video-mga, xorg-video-openchrome, xorg-video-r128, xorg-video-savage, xorg-video-vesa, xorg-video-vmware were updated

2015-02-13 nvidia proprietary driver was updated to 340.76

2015-02-07 xf86-video-ati driver updated to 6.4.16. However, without kernel DRI support for modern ATI video adapters, performance is modest.

2015-02-06 Mesa updated to 9.0.3

2015-02-05 PostgreSQL 8.4 removed

2015-02-05 Sun Studio indent in /usr/bin was replaced by GNU indent. Old one is preserved in /opt/sunstudio12.1/prod/bin/indent

2015-02-04 X11 util-macros was updated to 1.17.1, libX11 - to 1.6.2, xcb support in libX11 enabled

2015-02-03 X11 protocol headers were updated to fresh versions

2015-01-18 QT 4.8.6 is added.

2015-01-16 libdrm is updated to 2.4.58

2015-01-16 Ruby 2.2 is added. Ruby components sitll use ruby-19.

2015-01-10 curl is updated to 7.39.0

2015-01-07 mesa, xorg and X11 video drivers for intel and ati cards were rearranged to match natural package boundaries

2015-01-05 gnome-panel trusted extension patch and lockdown patch were removed during update to 2.32

2015-01-04 Nautilus trusted extension patch was removed during update to 2.32

2015-01-03 GTK is updated to 2.24

2014-12-19 PostgreSQL 9.4 is added. Prepare for removal of PostgreSQL 8.4 in a month.

2014-12-16 libncurses moved out of /usr/gnu to /usr

2014-12-15 nwam-manager updated to 1.151.0

2014-12-14 GNU Emacs updated to 24.3

2014-12-13 Python 3.4 updated to 3.4.2. It is compiled with pymalloc, so locations for includes, some libraries and binary modules changed

2014-12-04 tor updated to 0.2.4.24, rsyslog updated to 7.4.4

2014-12-02 Studio C++ libraries are no longer supported and are going to be removed. Current  versions of libraries are available here as tarballs: http://dlc.openindiana.org/c++-libs/

2014-11-25 ruby-19 is the default Ruby version. All Ruby consumers are switched to Ruby 1.9. Ruby 1.8 is dropped.

2014-10-04 Apache OpenOffice is updated to 4.1.1

2014-09-30 sic_team consolidation was moved from oi-build to oi-userland

2014-08-28 ftp daemon (earlier provided by illumos-gate wu-ftpd) is replaced by proftpd. Service network/ftp is renamed to service/proftpd. Now ftp daemon is running in standalone mode (previously it was inetd-managed service).

2014-08-12 gnome-pilot and gnome-pilot-link packages are obsolete now.

2014-08-04 System perl (/usr/perl5/bin/perl) now links to perl-516. Perl 5.16 was recompiled without -Dperl_static_inline="static" flag, which can affect perl ABI. Most of the Perl 5.10 modules were marked obsolete. Detail message is available in oi-dev ML: http://openindiana.org/pipermail/oi-dev/2014-August/003300.html

2014-08-01 OpenOffice 4.1.0 is available

2014-07-29 GDB is updated to 7.6

2014-07-19 Firefox is updated to 24.6.0 ESR

2014-07-18 Webkit was added to oi-userland. Devhelp and yelp were switched to webkit.

2014-07-04 OpenJDK is updated to 1.7.60

2014-07-04 GCC 4.8.3 is a default userland compiler now

2014-06-27 GCC is updated to 4.7.4.

2014-06-16 OpenIndiana /hipster repository was moved to http://pkg.openindiana.org/hipster-2014.1

2014-06-16 OpenSSL (library/security/openssl) is updated to 1.0.1h. Compatiblity bits are provided in the same package.

2014-06-04 Updated to Python 2.7.6

2014-05-08 Webmin is removed (no maintainer, removed upstream)

2014-04-17 OpenSSL (library/security/openssl) is updated to 1.0.1g. Compatiblity bits are provided in the same package.

2014-04-12 Remove LP-related desktop components (gnome-print, gnome-print-papi). ghex is also removed (it depends on them, removed upstream). 

2014-03-18 gstreamer was rebuilt. gstreamer/plugin/base and gstreamer/plugin/good are separate packages now

2014-03-12 slim_source was rebuilt with GCC

2014-02-27 oi-userland was switched to use new versioning scheme. If you build software, please ensure to test it with set environment variables COMPONENT_BUILD_ARGS=-j4 and USERLAND_ARCHIVES

2014-01-31 gnome-libs are separated in several packages. text/rarian files moved from /usr to /usr/g++. For compatibility symbolic links in /usr/bin were created to point to corresponding programs in /usr/g++. The library itself is no longer compatible, as it is rebuilt with g++.

2014-01-28 rapper binary from library/raptor was renamed to rapper-1 to avoid conflict with library/raptor2 package.

2014-01-16 Python 2.4 is deprecated

2014-01-15 Thunderbird is updated to 24.2.0

2014-01-08 Firefox is updated to 17.0.6 ESR, OpenJDK 1.7.45 and icedtea-web 6ec72d653144 are used as java browser plugin.

2013-12-10 IPS was updated. IPS GUI - package-manager and update-manager - was removed. If you hosted local IPS servers you have to recreate services, which supported these servers.  Procedure is the same (and described, for example, here http://wiki.illumos.org/display/illumos/Redistributing+built+packages ) , but old services just don't work after update.

2013-11-14 PostgreSQL 8.2 and 8.3 packages removed (replaced by PostgreSQL 9.3, which is now a default PostgreSQL version)
2013-10-11 PHP 5.2 removed (replaced by PHP 5.4)
2013-08-20 MariaDB 5.5 is used as default MySQL provider

2013-07-20 Perl was updated to 5.16 

Update instructions:

    1. To install new perl-516 firstly update perl-510. Old perl-510 ships hardlinks. It was updated to install mediated links. Note, it is just old repackaged perl 5.10.0 from /dev compiled with Sun Studio, only manifest was patched to deliver mediated links. Perl 5.10 is still used while compiling illumos-gate.
    2. If you just update old library/perl-5/database and other modules you'll receive new packages, which are just meta-packages, new packages will likely pull library/perl-5/*-516 packages and you'll stay without old modules, so remember to install corresponding library/perl-5/*-5100 packages after update (if someone is interested 5100 stands for perl 5.10.0). 
  • No labels