Child pages
  • Using Ruby on Rails 3.0.5 on O.I.
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 2 Next »

  1. install ruby
  2. "gem update --system" to update to latest gem tool.
  3. Install sqlite3 so that we have a database backend for testing.
  4. A quick check of installed Ruby stuff.
    oi@oi:~$ ruby -v
    ruby 1.8.7 (2009-06-12 patchlevel 174) [i386-solaris2.11]
    oi@oi:~$ gem -v
    1.6.2
    oi@oi:~$ gem env
    RubyGems Environment:
      - RUBYGEMS VERSION: 1.6.2
      - RUBY VERSION: 1.8.7 (2009-06-12 patchlevel 174) [i386-solaris2.11]
      - INSTALLATION DIRECTORY: /var/ruby/1.8/gem_home
      - RUBY EXECUTABLE: /usr/ruby/1.8/bin/ruby
      - EXECUTABLE DIRECTORY: /var/ruby/1.8/gem_home/bin
      - RUBYGEMS PLATFORMS:
        - ruby
        - x86-solaris-2.11
      - GEM PATHS:
         - /var/ruby/1.8/gem_home
         - /export/home/oi/.gem/ruby/1.8
         - /usr/ruby/1.8/lib/ruby/gems/1.8
      - GEM CONFIGURATION:
         - :update_sources => true
         - :verbose => true
         - :benchmark => false
         - :backtrace => false
         - :bulk_threshold => 1000
      - REMOTE SOURCES:
         - http://rubygems.org/
    oi@oi:~$ uname -a
    SunOS oi 5.11 oi_148 i86pc i386 i86pc
    oi@oi:~$
    
    
  • No labels